Configure microKorg for our plug-in

Forums Korg microKxR AudioUnit & VST Editor / Librarian microKxR Online User Guides Configure microKorg for our plug-in

This topic contains 6 replies, has 3 voices, and was last updated by Novaline – Mystery Islands Music Support 2 weeks ago.

  • Author
    Posts
  • #39440

    Jani
    Admin
    @mystery-islands

    Instructions what to do before inserting our plug-in to project

    First we need to make sure the hardware is ready to communicate with the software. In order to do so, we need to make sure that some pre-required settings are set accordingly.

    Plug your MIDI cables to the MIDI device and Audio Jacks to your mixer / soundcard.
    MIDI out from synth to MIDI device in and vice versa. No MIDI thru or other ports.

    Fire up your microKorg and enter MIDI settings with “EDIT SELECT 2” knob.

    Set MIDI CH for your microKorg as you wish – just remember what it is when launching our plug-in.
    Set LOCAL to OFF if you control your microKorg sound engine via master keyboard.
    Set CLOCK to Ext if you don’t plan to use the arpeggiator. Arpeggiator work only when microKorg receives MIDI clock data.

    Lets adjust some MIDI settings which are hidden from main panel. In order to access these settings, follow the instructions given here.

    Hold down the SHIFT key and press the 4 key – Display indicates FLT.

    • Enable program change: Turn knob 1 until display says P-E.
    • Enable control change: Turn knob 2 until display says C-E.
    • Enable System Exclusive: Turn knob 4 until display says E-E.

    Exit this view by clicking shift – Display returns to normal state.

    Hold down the SHIFT key and press the 8 key – Display indicates utP.

    • Disable Write Protect: Turn knob 1 until display says oFF.

    Exit this view by clicking shift – Display returns to normal state.

    You might have to adjust the write protect setting each time you power-up your microKorg, so check that time after time to make sure it is oFF.

    All set! We are now ready to open our plug-in in DAW!

    To get more information about how to adjust your synth, read the Korg microKorg User Manual.

    Put your setup details in the signature to help us understand your setup, thank you!

    Access Virus C & Virus TI2, Clavia Nord Rack 2 & Nord Rack 3, Roland JP-8000 & JP-8080, Novation Nova, Supernova Rack, Supernova 2 Rack, UltraNova & KS-Rack, Waldorf Q Rack, microQ, Pulse + & Blofeld SL, Korg MS2000R, Radias & microKorg, Yamaha AN1x, AN200, CS6x + PLG150-AN & EX5, M-Audio Venom, 3x UA Apollo Quad, Satellite Quad, PoCo x8, MOTU micro lite, 2x Emagic AMT8, MacPro 6,1

    Attachments:
  • #45996

    braduro
    Community Folk
    @braduro

    Hi Jani,

    Now there is no sound coming out of my mK. I’m new to the mK in general, so I’m sure there’s a clear explanation. It was working fine on its own yesterday and before this setup.

    But I know my software (Live) I have my midi incoming and set up monitoring correctly. I’m using a focusrite clarets 4pre, and I’ve configured it for direct routing for the sake of simplifying this troubleshooting. That’s not to say I know your editor librarian software either, for example the global settings. But I do see midi signal, and the program changes appear to register on the korg.

    I have an audio track that sees the inputs assigned from my interface, and monitored correctly. Neither in the drop down menus nor on the volume meter itself is there any indication that signal is passing. If I plug in my headphones or a portable speaker directly into the headphone jack, nothing is passing. And the volume knob on the mK is not helping…

    As a side note, when these instructions as for Shift+Program button 4, could you tell me what turning knob 3 does? You might as well complete the set, because if any of those are turned in this process, even the ones not prescribed in this setup, couldn’t that alter the behavior and outcome of the korg?

  • #45998

    braduro
    Community Folk
    @braduro

    ha! and as mysteriously as it didn’t work, it works now. Couldn’t repeat what I did aside from send a program change and turn a couple knobs…

  • #46000

    braduro
    Community Folk
    @braduro

    Okay, onward to a different problem.

    Every program change to the microkorg sounds like a saw wave INIT, even if INIT is not selected as the patch. Even the randomize. I see that the corresponding knobs turn on the plugin when I move them on the mK. But for example, the cut off on the mK is not effected, even if you see that it is mapped correctly. No change in timbre. And the changes to the octaves from the plugin register on the mK.

    While on the topic, is there an easy way, say by double clicking a patch within the library view, to switch directly to that patch? I mean it looks like a menu, yeah? So why couldn’t one just select from the menu?

    • #46002

      braduro
      Community Folk
      @braduro

      Oh, and the program change won’t work from the mK. Switch the select knob or press a number, and it bounces back to A.11 no matter what you do. I imagine that’s the intended behavior?

  • #46114

    braduro
    Community Folk
    @braduro

    okay, local mode disengaged. Of course. Sequencers in DAW work fine. But still not getting any responsiveness to patch changes from editor. Seeing that knobs on mK will change settings on the plugin but nothing effects the sound on the mK…

  • #47319

    Novaline – Mystery Islands Music Support
    Community Folk
    @novaline

    hi braduro,

     

    have you gone through all the steps before using the editor? (hardware instructions, loopmidi & midi-ox) and do you use the latest version of the editor?

    if something else doesnt change, please report this to the support thread.

     

    regards

    novaline

    ANALOG & VA IS THE SHIZZLE!

    OWNER OF : ACCESS VIRUS A, JP8080, JP8000, SUPERNOVA

You must be logged in to reply to this topic.