Some questions on the editor

Forums Korg MS2KxR AudioUnit & VST Editor / Librarian MS2KxR Support Some questions on the editor

This topic contains 8 replies, has 2 voices, and was last updated by Novaline – Mystery Islands Music Support 3 weeks, 3 days ago.

  • Author
    Posts
  • #45906

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    Hello,

    I posted this in the wrong section, here is the right place :)

    I tried to set up the MS-2000 editor in Reaper x64 on windows7. It took a few attemps to get it registered but it works now.

    Because I disabled the midi ports in Reaper, I cannot make a track and load the MS-2000 midi out as an input on my track.

    Is it correct that I need to install 2 other programs to get this working? Midi-ox and a virtual midi cable? And that both of them need to run all the time while producing? I tried this out and it seems to give some latency at my end.

    I have a midi merger with 4 midi ins and 2 midi outs. Is it an option to connect the midi out of the synth to the midi in of the merger and connect 1 midi out of the merger to port IN1 from a midi interface and the second merger output to port IN2 of the interface . So I can skip those programs?

    Couldn’t find a manual either. I can’t get my head around the librarian. I just don’t get how it works. Why there are 2 different windows and stuff. Is there an explanation somewhere? I have a lot of MS-2000 presets, digitally stored on PC. Would like to load those in the plugin, play them and make my own bank and send that to the synth. Can someone help me there?

    Thanks in advance,

    Jan

  • #47225

    Novaline – Mystery Islands Music Support
    Moderator
    @novaline

    Hi Jan,

    yepp now this is the right one :)

    i´ll copy the same as i did response on your previous one :)

     

    yes it is correct that you need to install both Loopmidi and MIDI-ox.

    1. install loopmidi and create your virtual channels (´´your synth IN´´ & ´´your synth´´ OUT)

    2. install midi-ox and make the connections there. JPG files will be uploaded as a demonstration.

    3. after this. go to your DAW and set up your midi port on your hardware on the OUTPUT section. nothing on the INPUT, only OUTPUT.

    4. upload the editor and setup your midi ports (for example midi in 1 & midi out 2) and not the virtual ones

    5. sync data to hardware and fire away!

    i hope this helps.

    if any more questions, just ask.

    regards

    Novaline

    ANALOG & VA IS THE SHIZZLE!

    OWNER OF : ACCESS VIRUS A, JP8080, JP8000, SUPERNOVA

    Attachments:
  • #47755

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    So…I tried this setup and this setup enables me to play the HW keyboard and record the notes in my DAW. But that was never the problem.

    I am trying to record the notes from the HW arp into my DAW and with this setup it only records the note that triggers the arp.

     

  • #47762

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    The other thing that is very confusing is the fact that I can record the notes from the HW keyboard perfectly fine in my DAW without midi ox and Loopmidi. the only thing I have to do for that, is enabling my ports in my DAW…

    Have you considered that the RME midi interfaces have a feature that only few midi interfaces have? It is able to share the ports between different applications just fine.

    So for now I can also play notes on the HW with the arp activated and when I press latch and change the tempo in my DAW, I can control the arpspeed there without midi-ox or loopmidi. I am just not able to record the arpnotes into my daw, it only records the arptriggernotes I play. I would like to record the arpnotes to edit them in my DAW afterwards.

  • #47763

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    I found the answer on my own. To get the arpnotes into your daw you have to set it in globals to position PostKBD.

     

  • #47764

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    And a last note. When you enable the input port in Reaper, you can choose between-Enabling input from this device and Enabling input for control messages. When you only choose the first option there is no reason to disable the ports. I did not check with the second option, but there is no need for that because the plugin is taking care of that right?

  • #47864

    Novaline – Mystery Islands Music Support
    Moderator
    @novaline

    Hi,

    yes, plugin takes care of the control messages so user does not have to get control messages twice in the DAW / plugin domain. OR you can enable both, but then disable DAW control options from advanced midi settings page.

     

    hope this helps

     

    regards

    team MIM

    ANALOG & VA IS THE SHIZZLE!

    OWNER OF : ACCESS VIRUS A, JP8080, JP8000, SUPERNOVA

  • #47896

    nr1killabee@gmail.com
    Community Folk
    @nr1killabeegmail-com

    OR you can enable both, but then disable DAW control options from advanced midi settings page.

    That’s a cool tipp! Will try when I have problems again.

  • #47903

    Novaline – Mystery Islands Music Support
    Moderator
    @novaline

    Hello again,

    You do that. If anything else let us know

    Closing this case unless something else is coming up.

     

    I hope you are satisfied with the answers and the help so far.

    Regards

    Novaline

    ANALOG & VA IS THE SHIZZLE!

    OWNER OF : ACCESS VIRUS A, JP8080, JP8000, SUPERNOVA

You must be logged in to reply to this topic.