Help Center

Connection Timed Out!

Troubleshooting Knowledge Level

Troubleshooting articles for our products. If there is no solution from our documents, please open a ticket

If you get “connection time out” message with our plug-in, there are several ways to tackle the issue.

In this first part, we are making sure that the message is really true because sometimes the plug-in display doesn’t update the status properly. OK, so let’s get into it!

Confirm Connection Error

If the warning message appears while you are making the first connection with the hardware and software, the connection might be OK, even when you see the warning.

To test this, simply enter Patch Librarian, select random program slot from left / upper program selection list (edit list), click bank edit menu, select request patch data, click from current slot to librarian (or something along that line).

If the patch / program comes in to the slot as expected, the connection should be very much alive and you can ignore the message.

If the error is still there and you can’t see program / patch coming into the librarian slot you just selected, then we have an issue – Move on to next part!

Finding the issue, fixing the issue

All right, let’s find out why the issue is still among us and have it fixed. Make some notes to yourself, so you remember if this occurs again.

Now, this might be very obvious check, but I have seen this happened dozens of times already:

Checking the cables

Check the MIDI connections from your hardware to the MIDI interface. I really mean it: check it.
There has been several cases, where one has had his MIDI cables mixed up, connected in a wrong spot, wrong port, wrong way, looped in, you name it.

  1. MIDI Out from your Hardware should go to your MIDI interface Input PORT X.
  2. MIDI Out from your MIDI Interface Output PORT X should go to your Hardware MIDI Input.
  • There has been a case where MIDI out from synth went accidentally back to MIDI input of the synth (long cables, it happens…)
  • There has been a case where MIDI out from synth went to MIDI interface midi out port. Not gonna work.
  • There has been a case where MIDI thru from synth went to MIDI interface midi input, again, not gonna work.
  • There has been a case where MIDI cable was simply dead. New cable fixed the issue immediately.
  • There has been more than dozen cases, where MIDI interface was simply unable to process large amounts of SysEx data.

 

Check the interface & ports

Some MIDI interfaces are simply not strong enough to support System Exclusive message transfers. Try another MIDI interface. And if the MIDI interface has multiple ports, try different ports as well. That has made a difference before, so it might be answer in this case as well!

Check the Hardware settings

Check the settings of the hardware, again. Pretty common issue is that one has had a wrong checkbox marked in the plug-in or in the hardware preventing the data flow from happening as expected. Like microKorg goes absolutely mental when the MIDI Clock is set to INTERNAL mode. **** me what a hassle. Keep the MIDI clocks in EXTERNAL mode if possible.

Data request Interval

Check the plug-in request interval setting. You can find this dropdown list from the Patch Librarian page, usually in between the two program lists (where lists are stacked above each other) or from either side of the librarian window in any other cases.

If the interval is set too low, it usually causes issues – It all comes down to the computing power, length of the MIDI cables, interference of data by other apps etc. When you request data in the plug-in, stay calm and have a sip of coffee / tea while the data flows in.

Mode of Operation

Our plug-ins are designed to work in MULTI mode when there is multimode available in the hardware.

We are not going to support single mode operation ever. That is a statement I’ve done several years ago and I will stick to it. Reason is simple: in Multimode, we have a much wider access to the synthesizers parameters, presets and capabilities than in the Single mode.

There has been arguments such as:

  • Single mode makes the synth work better. 100% False statement. Prove me wrong.
  • Single mode gives me more polyphony. 100% true, IF you don’t play other parts at the same time.

Summing-up: Keep the hardware in multi mode when there is one available and the plug-in should work.

Device ID…Global MIDI channel

Now, as I have written in the “hardware configurations” Device ID plays a major role in the plug-in / hardware game. Just make sure they match and try again. Usually the values we have set initially in the plug-in are working out of the box. What I mean is: Copy the Device ID from the plug-in to the hardware and give it a go!

Sometimes the issue might be in the global MIDI channel setting instead, so double check that as well.

If you can’t find any help from this article, open a support ticket with us and let’s figure it out.

0
0
91
Rate this article

Spread the word with your community ❤️ Thank you!

0 Shares
Tweet
Share
Reddit
Share
Share
Happy New Year - Use coupon HAPPY2021 in cart or checkout page!  Shop Now!
close
open